package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((feature/.{1,5})|(maint/.{1,5})|(doc/.*)|(fix/.*)|(trivial/.*)|(revert-.*)|(release/.*)|(renovate/.*))$`)
var str = `fix/757`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}