$re = '/^((feature/.{1,5})|(maint/.{1,5})|(doc/.*)|(fix/.*)|(trivial/.*)|(revert-.*)|(release/.*)|(renovate/.*))$/';
$str = 'fix/757';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);