using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"&page_number=\d+$";
string input = @"http://url.com/search/?location=london&page_number=1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}