re = /&page_number=\d+$/m
str = 'http://url.com/search/?location=london&page_number=1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end