import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "StatementId:[ ](?:\\[([^\\[\\]]*)\\]|(.*?)),.*UserId:[ ]([0-9]*)";
final String string = "StatementId: [12345], UserId: 8756\n\n"
+ "StatementId: 12345, UserId: 8756\n\n"
+ "StatementId: [12345,6789], UserId: 8756";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}