const regex = /StatementId:[ ](?:\[([^\[\]]*)\]|(.*?)),.*UserId:[ ]([0-9]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('StatementId:[ ](?:\\[([^\\[\\]]*)\\]|(.*?)),.*UserId:[ ]([0-9]*)', 'g')
const str = `StatementId: [12345], UserId: 8756
StatementId: 12345, UserId: 8756
StatementId: [12345,6789], UserId: 8756`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}