import re
regex = re.compile(r"StatementId:[ ](?:\[([^\[\]]*)\]|(.*?)),.*UserId:[ ]([0-9]*)")
test_str = ("StatementId: [12345], UserId: 8756\n\n"
"StatementId: 12345, UserId: 8756\n\n"
"StatementId: [12345,6789], UserId: 8756")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")