import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(.+)(?:\"\\s|\">)";
final String string = "<script src=\"$/frontend/privacy/js/flip/jquery.flip.min.js\"></script>\n"
+ "<script src=\"$/frontend/privacy/js/privacy.js\"></script>\n"
+ "<script src=\"$/frontend/global/assets/js/jsplate.js\"></script>\n"
+ "<script src=\"$/frontend/privacy/js/family_members.js\"></script>\n"
+ "<script src=\"$/frontend/privacy/js/relationships.js\"></script>\n"
+ "<script src=\"$/frontend/privacy/js/invitation.js\"></script>\n\n"
+ "<link href=\"$/frontend/global/assets/css/includes/setup.css\" rel=\"stylesheet\"/>\n"
+ "<link href=\"$/frontend/privacy/css/privacy.css\" rel=\"stylesheet\"/>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}