// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""(.+)(?:"\s|">)"#).unwrap();
let string = "<script src=\"$/frontend/privacy/js/flip/jquery.flip.min.js\"></script>
<script src=\"$/frontend/privacy/js/privacy.js\"></script>
<script src=\"$/frontend/global/assets/js/jsplate.js\"></script>
<script src=\"$/frontend/privacy/js/family_members.js\"></script>
<script src=\"$/frontend/privacy/js/relationships.js\"></script>
<script src=\"$/frontend/privacy/js/invitation.js\"></script>
<link href=\"$/frontend/global/assets/css/includes/setup.css\" rel=\"stylesheet\"/>
<link href=\"$/frontend/privacy/css/privacy.css\" rel=\"stylesheet\"/>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}