use strict;
my $str = ' \'cpt\' => \'application/mac-compactpro\',
\'cpt\' => \'application/x-compactpro\',
\'cpt\' => \'application/x-cpt\',
\'crl\' => \'application/pkcs-crl\',
\'crl\' => \'application/pkix-crl\',
\'crt\' => \'application/pkix-cert\',
\'crt\' => \'application/x-x509-ca-cert\',
\'crt\' => \'application/x-x509-user-cert\',
\'csh\' => \'application/x-csh\',
\'csh\' => \'text/x-script.csh\',
\'css\' => \'application/x-pointplus\',';
my $regex = qr/^\s*'.*?'\s*=>\s*('.*?',?)$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";