#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<tr\b[^<]*>[^<]*(?:<(?!tr\b)[^<]*)*HelloWorld[^<]*(?:<(?!\/tr>)[^<]*)*<\/tr>"
Local $sString = "<tr>" & @CRLF & _
"OtherElement" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>more " & @CRLF & _
"HelloWorld" & @CRLF & _
"text" & @CRLF & _
"here" & @CRLF & _
"</tr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")