re = /<tr\b[^<]*>[^<]*(?:<(?!tr\b)[^<]*)*HelloWorld[^<]*(?:<(?!\/tr>)[^<]*)*<\/tr>/
str = '<tr>
OtherElement
</tr>
<tr>more
HelloWorld
text
here
</tr>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end