const regex = /<tr\b[^<]*>[^<]*(?:<(?!tr\b)[^<]*)*HelloWorld[^<]*(?:<(?!\/tr>)[^<]*)*<\/tr>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<tr\\b[^<]*>[^<]*(?:<(?!tr\\b)[^<]*)*HelloWorld[^<]*(?:<(?!\\\/tr>)[^<]*)*<\\\/tr>', '')
const str = `<tr>
OtherElement
</tr>
<tr>more
HelloWorld
text
here
</tr>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}