import re
regex = re.compile(r"<tr\b[^<]*>[^<]*(?:<(?!tr\b)[^<]*)*HelloWorld[^<]*(?:<(?!\/tr>)[^<]*)*<\/tr>")
test_str = ("<tr>\n"
"OtherElement\n"
"</tr>\n"
"<tr>more \n"
"HelloWorld\n"
"text\n"
"here\n"
"</tr>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")