const regex = /^(.)\1{3,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.)\\1{3,}', 'g')
const str = `CCCgshdbuasvbd`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);