use strict;
my $str = 'CCCgshdbuasvbd';
my $regex = qr/^(.)\1{3,}/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";