$re = '/^(.)\1{3,}/';
$str = 'CCCgshdbuasvbd';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;