import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:\\.|#)(?:[a-z]|[A-Z]|[0-9]|\\s|\\.|#|-|:|&|,)+?\\{(?:\\s|\\n)*(?:\\/\\*export\\*\\/)(?:.|\\n)*?\\})";
final String string = ".something {\n"
+ " background-color:pink;\n"
+ "}\n\n"
+ ".somethingelse {\n"
+ " /*export*/\n"
+ " text-align: right;\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}