$re = '/^((?:\.|#)(?:[a-z]|[A-Z]|[0-9]|\s|\.|#|-|:|&|,)+?{(?:\s|\n)*(?:\/\*export\*\/)(?:.|\n)*?})/m';
$str = '.something {
background-color:pink;
}
.somethingelse {
/*export*/
text-align: right;
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);