re = /^((?:\.|#)(?:[a-z]|[A-Z]|[0-9]|\s|\.|#|-|:|&|,)+?{(?:\s|\n)*(?:\/\*export\*\/)(?:.|\n)*?})/m
str = '.something {
background-color:pink;
}
.somethingelse {
/*export*/
text-align: right;
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end