const regex = /(\r\n|^).{16,}(?=(\r\n|$))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\r\\n|^).{16,}(?=(\\r\\n|$))', 'gmi')
const str = `фундаментные
опора подвижная
закладные изделия мн 57 1
изготовление металлоконструкций`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}