$re = '/(\r\n|^).{16,}(?=(\r\n|$))/mix';
$str = 'фундаментные
опора подвижная
закладные изделия мн 57 1
изготовление металлоконструкций';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);