import re
regex = re.compile(r"""
(\r\n|^).{16,}(?=(\r\n|$))
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = ("фундаментные\n"
"опора подвижная\n"
"закладные изделия мн 57 1\n"
"изготовление металлоконструкций")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")