re = /(\r\n|^).{16,}(?=(\r\n|$))/mix
str = 'фундаментные
опора подвижная
закладные изделия мн 57 1
изготовление металлоконструкций'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end