using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:MIM#|OMIM:|(?<!:))(\d{6})\b";
string input = @"111111;Dystonia-1,222222,OMIM:555555; 3333333 Dystonic disorder1,MIM#444444";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}