const regex = new RegExp('\\b(?:MIM#|OMIM:|(?<!:))(\\d{6})\\b', 'gm')
const str = `111111;Dystonia-1,222222,OMIM:555555; 3333333 Dystonic disorder1,MIM#444444`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}