const regex = /apples|bananas|carrots/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('apples|bananas|carrots', '')
const str = `This allows bananas to appear anywhere in the source text, confirming that the source contains at least of of the choices.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}