import Foundation
let pattern = #"apples|bananas|carrots"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"This allows bananas to appear anywhere in the source text, confirming that the source contains at least of of the choices."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}