$re = '/apples|bananas|carrots/';
$str = 'This allows bananas to appear anywhere in the source text, confirming that the source contains at least of of the choices.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);