re = /apples|bananas|carrots/
str = 'This allows bananas to appear anywhere in the source text, confirming that the source contains at least of of the choices.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end