#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(['"])(?:\\\1|(?!\1).)*?\1"
Local $sString = "a='string1'" & @CRLF & _
"b='string2'" & @CRLF & _
"c="string3"" & @CRLF & _
"alert("string\"4")" & @CRLF & _
"alert('string\'5')"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")