import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(['\"])(?:\\\\\\1|(?!\\1).)*?\\1";
final String string = "a='string1'\n"
+ "b='string2'\n"
+ "c=\"string3\"\n"
+ "alert(\"string\\\"4\")\n"
+ "alert('string\\'5')";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}