re = /(['"])(?:\\\1|(?!\1).)*?\1/m
str = 'a=\'string1\'
b=\'string2\'
c="string3"
alert("string\\"4")
alert(\'string\\\'5\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end