using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(['""])(?:\\\1|(?!\1).)*?\1";
string input = @"a='string1'
b='string2'
c=""string3""
alert(""string\""4"")
alert('string\'5')";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}