import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^- .+\\n.+\\n.+";
final String string = "System.Management.Automation.RemoteException\n"
+ "name: CLD:HYB_Z_BASIS_ADMIN_SUPER\n"
+ "description: Basis Administrator\n"
+ "readOnly: \n"
+ "roleReferences:\n"
+ "- roleTemplateAppId: it!b2455\n"
+ " roleTemplateName: AuthGroup_Administrator\n"
+ " name: AuthGroup_Administrator\n"
+ "- roleTemplateAppId: it!b2455\n"
+ " roleTemplateName: AuthGroup_BusinessExpert\n"
+ " name: AuthGroup_BusinessExpert\n"
+ "OK";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}