import Foundation
let pattern = #"(?m)^- .+\n.+\n.+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
System.Management.Automation.RemoteException
name: CLD:HYB_Z_BASIS_ADMIN_SUPER
description: Basis Administrator
readOnly:
roleReferences:
- roleTemplateAppId: it!b2455
roleTemplateName: AuthGroup_Administrator
name: AuthGroup_Administrator
- roleTemplateAppId: it!b2455
roleTemplateName: AuthGroup_BusinessExpert
name: AuthGroup_BusinessExpert
OK
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)