import re
regex = re.compile(r"(?m)^- .+\n.+\n.+")
test_str = ("System.Management.Automation.RemoteException\n"
"name: CLD:HYB_Z_BASIS_ADMIN_SUPER\n"
"description: Basis Administrator\n"
"readOnly: \n"
"roleReferences:\n"
"- roleTemplateAppId: it!b2455\n"
" roleTemplateName: AuthGroup_Administrator\n"
" name: AuthGroup_Administrator\n"
"- roleTemplateAppId: it!b2455\n"
" roleTemplateName: AuthGroup_BusinessExpert\n"
" name: AuthGroup_BusinessExpert\n"
"OK")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")