package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\p{L}+\b`)
var str = `abalbal_asldad 23sadaskld adasdas3123 abalbal asldad 23 sadaskld 3123 adasdas`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}