$re = '/\b\p{L}+\b/u';
$str = 'abalbal_asldad 23sadaskld adasdas3123 abalbal asldad 23 sadaskld 3123 adasdas';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);