re = /\b\p{L}+\b/
str = 'abalbal_asldad 23sadaskld adasdas3123 abalbal asldad 23 sadaskld 3123 adasdas'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end