package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?\/\/([^:\/\s]+)`)
var str = `https://www.google.com/
https://www.google.com/search?q=Regular+Expressions&num=1000
https://google.com:80`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}