$re = '/^.*?\/\/([^:\/\s]+)/m';
$str = 'https://www.google.com/
https://www.google.com/search?q=Regular+Expressions&num=1000
https://google.com:80';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);