re = /^.*?\/\/([^:\/\s]+)/m
str = 'https://www.google.com/
https://www.google.com/search?q=Regular+Expressions&num=1000
https://google.com:80'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end