using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{8}#[\w\d\?!]{15}";
string input = @"FF_WE_GE#Ww!00NnFfHH22Bndcth52?D
asdFF_WE_GE#Ww!00NnFfHH22Bndcth52?D";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}