$re = '/.{8}#[\w\d\?!]{15}/m';
$str = 'FF_WE_GE#Ww!00NnFfHH22Bndcth52?D
asdFF_WE_GE#Ww!00NnFfHH22Bndcth52?D';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);