re = /.{8}#[\w\d\?!]{15}/m
str = 'FF_WE_GE#Ww!00NnFfHH22Bndcth52?D
asdFF_WE_GE#Ww!00NnFfHH22Bndcth52?D'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end