// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)>(.*?)<\/").unwrap();
let string = "<div style =\"line-height: 20px;\">
<span>Content1</span>
<span>Content2</span>
<p> < 0.15, < 0.12 </p>
</ div>'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}