using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(\[?)(?P<shortcodename>\w\S+)(?![/w-])([^\]\/]*(?:\/(?!\])[^\]\/]*)*?)(?:(\/)\]|\](?:([^\[]*(?:\[(?!\/\2\])[^\[]*)*)\[\/\2\])?)(\[?)";
string input = @"
[openandclose src=""1234"" id=""abc""]some content[/openandclose]
[openwithattrs src=""1234"" id=""abc""]
[mmbox_with-attrs title=""TOOL: Track Your Net Worth - Personal Capital"" link=""https://go.millennialmoney.com/personal-capital/"" image=""https://millennialmoney.com/wp-content/uploads/2020/05/personal-capital-square.jpg"" ctatext=""Get Started!"" desc=""With Personal Capital, you can see your net worth, analyze investments, and discover any hidden fees you weren’t aware of before – as well as set spending and saving goals."" price=""FREE"" color=""#32C4F3""]
[HL_QUOTER]
[open_only-]
[mmtoplist_ma type=""Auto"" max=""2"" header=""0""]
[tmf_investnow500 source=""isammtxt0000006"" header=""Where to invest $1000 right now"" aside=""Even More Stock Picks"" link=""https://www.fool.com/order/fe_offers/wf/602d8976-8f2f-41c3-9ddf-1ab6c2b5ba06?c=sa-inv-btr&amp;utm_campaign=topmillennialtrends&amp;utm_medium=ecap_widget&amp;utm_source=millennialmoney&amp;campaign=sa-bbn-evergreen""]
[earningPotential amount=""$50,371"" timeframe=""yr""] [earningPotential]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}