import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(\\[?)(?P<shortcodename>\\w\\S+)(?![/w-])([^\\]\\/]*(?:\\/(?!\\])[^\\]\\/]*)*?)(?:(\\/)\\]|\\](?:([^\\[]*(?:\\[(?!\\/\\2\\])[^\\[]*)*)\\[\\/\\2\\])?)(\\[?)";
final String string = "\n"
+ "[openandclose src=\"1234\" id=\"abc\"]some content[/openandclose]\n\n"
+ "[openwithattrs src=\"1234\" id=\"abc\"] \n\n"
+ "[mmbox_with-attrs title=\"TOOL: Track Your Net Worth - Personal Capital\" link=\"https://go.millennialmoney.com/personal-capital/\" image=\"https://millennialmoney.com/wp-content/uploads/2020/05/personal-capital-square.jpg\" ctatext=\"Get Started!\" desc=\"With Personal Capital, you can see your net worth, analyze investments, and discover any hidden fees you weren’t aware of before – as well as set spending and saving goals.\" price=\"FREE\" color=\"#32C4F3\"]\n\n"
+ "[HL_QUOTER]\n\n"
+ "[open_only-]\n\n"
+ "[mmtoplist_ma type=\"Auto\" max=\"2\" header=\"0\"]\n\n"
+ "[tmf_investnow500 source=\"isammtxt0000006\" header=\"Where to invest $1000 right now\" aside=\"Even More Stock Picks\" link=\"https://www.fool.com/order/fe_offers/wf/602d8976-8f2f-41c3-9ddf-1ab6c2b5ba06?c=sa-inv-btr&amp;utm_campaign=topmillennialtrends&amp;utm_medium=ecap_widget&amp;utm_source=millennialmoney&amp;campaign=sa-bbn-evergreen\"]\n\n"
+ "[earningPotential amount=\"$50,371\" timeframe=\"yr\"] [earningPotential]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}