import re
regex = re.compile(r"\[(\[?)(?P<shortcodename>\w\S+)(?![/w-])([^\]\/]*(?:\/(?!\])[^\]\/]*)*?)(?:(\/)\]|\](?:([^\[]*(?:\[(?!\/\2\])[^\[]*)*)\[\/\2\])?)(\[?)")
test_str = ("\n"
"[openandclose src=\"1234\" id=\"abc\"]some content[/openandclose]\n\n"
"[openwithattrs src=\"1234\" id=\"abc\"] \n\n"
"[mmbox_with-attrs title=\"TOOL: Track Your Net Worth - Personal Capital\" link=\"https://go.millennialmoney.com/personal-capital/\" image=\"https://millennialmoney.com/wp-content/uploads/2020/05/personal-capital-square.jpg\" ctatext=\"Get Started!\" desc=\"With Personal Capital, you can see your net worth, analyze investments, and discover any hidden fees you weren’t aware of before – as well as set spending and saving goals.\" price=\"FREE\" color=\"#32C4F3\"]\n\n"
"[HL_QUOTER]\n\n"
"[open_only-]\n\n"
"[mmtoplist_ma type=\"Auto\" max=\"2\" header=\"0\"]\n\n"
"[tmf_investnow500 source=\"isammtxt0000006\" header=\"Where to invest $1000 right now\" aside=\"Even More Stock Picks\" link=\"https://www.fool.com/order/fe_offers/wf/602d8976-8f2f-41c3-9ddf-1ab6c2b5ba06?c=sa-inv-btr&amp;utm_campaign=topmillennialtrends&amp;utm_medium=ecap_widget&amp;utm_source=millennialmoney&amp;campaign=sa-bbn-evergreen\"]\n\n"
"[earningPotential amount=\"$50,371\" timeframe=\"yr\"] [earningPotential]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")